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Chapter 3  Introduction to the FASTDATA Site Module

�  Overview

The FASTDATA Site Module is a graphical user interface (GUI)/Windows® computer
application that runs in Microsoft Windows NT®, Windows 95®, and Windows 98®. Generally,
GUI/Windows® applications share certain conventions that make them easier to use than non-
GUI or MS-DOS (disk operating system) applications. For example, a GUI/Windows®
application lets you have more than one application window open at the same time. Having
more than one window open simultaneously is handy because you can switch back and forth
between windows that contain related data. Multiple open windows also allow you to copy and
paste text from one window into another. Another feature of a GUI/Windows® application is the
consistent use of menus on a menu bar. Becoming familiar with these conventions will help you
learn how to use FASTDATA.

This chapter addresses the appearance, windows, and controls that let you navigate your way
through the FASTDATA Site application. For information on the FASTDATA Site menus,
buttons, keyboard and mouse inputs, and standard window controls that let you make selections
and initiate application processes, refer to this chapter. This chapter also discusses several Site
Module windows that are not associated with any specific main process window. These
windows include the Change Site Password, the Change FY, Site Selection, Customize
Toolbars, Printer Setup, About FASTDATA Site, Release Notes, Select Document, and Print
Multiple Documents windows. Throughout this manual, whenever a window is discussed in
detail, a list of window objects for the specific window is provided. The window objects include
all controls and text on the window.

Tip  A useful resource for additional information on Windows and its associated terminology is
the Windows Help file. To open the file select the taskbar Start button, then select Help.

Main FASTDATA Site Window
After you log into the FASTDATA Site Module and select an activity, the application frame will
display. When the Site Module is running, two buttons display on the Windows taskbar: the
FASTDATA application button and the SQL FASTDATA button. Both are labeled FASTDATA.
The SQL button indicates the database engine is up and running. Under normal circumstances,
you will never use the SQL FASTDATA taskbar button.
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Title Bar
On the application frame, the title bar contains the title of the FASTDATA Site Module, the FA
activity associated with your site, and the site you selected when you logged into the
application. The main window title bar also contains three buttons in the upper right corner: the
Minimize, Maximize/Restore, and Close buttons.

The Minimize button will clear but not close the FASTDATA Site application from your display.
The Site Module will continue to run when minimized. When minimized, a FASTDATA Site
button in the Windows taskbar lets you know the application is still running. To restore
FASTDATA to its previous size, left-click the FASTDATA Site button on the taskbar.

If the FASTDATA Site window is not displaying at its largest possible size, the
Maximize/Restore button will make the FASTDATA Site window as big as it can be. If the
FASTDATA Site window is not at its maximum size, the Maximize button will appear as a single
square representing a window. If the FASTDATA Site window is at its maximum size, the
Maximize button will appear as two, overlapping windows. Selecting the Maximize button when
the display is already as big as it can be will change the display to its previous size.

The Close button will close the FASTDATA Site application. Do not select the Close button
unless you’re sure you wish to shut down FASTDATA.

Every window in FASTDATA has a title bar. When you select the Maximize, Minimize, or
Close button on a window other than the application frame, the selected button action will apply
to the current window rather than the FASTDATA application frame. For example, if you select
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the Close button on the New Source NC2275 window title bar, the New Source NC2275
window will close although the FASTDATA application will remain open.

Menu Bar
The menu bar contains the main FASTDATA Site menus. Select a menu by clicking on it or by
typing its access key. The access key for each menu is the underlined letter in the menu label.
For example, on the File menu, the underlined F indicates you can enter ALT+F on your
keyboard to open the File menu. With the File menu open, select from the menu by clicking on
the desired item or by typing the desired item’s access key. For example, you can select the
File menu Exit item by clicking on it or by typing x.

When you open the FASTDATA Site Module, the menus that display and their contents will
change after you open another window. For example, when you select the File menu with only
the main application window open, it contains 12 options. After opening the Display SF1164
window, additional menus will display and the contents of the initial menus will expand. For
example, the File menu will contain several more items and View and Window menus will
appear on the menu bar.

The display and availability of menu items depends on the active FASTDATA window, the data
you have selected, if any, and your Site security access settings. For example, if the Fund
Administrator (FA) has assigned you a Reports, Inquiries No Access setting for Site Security
in the FASTDATA FA Module, the Reports menu item will not display. If a menu item is
temporarily unavailable, it will display as gray rather than black text. You cannot select gray (or
lightened) menu items. Black (or darkened) items are available for selection.

The sample menu options shown in Figures 3.2 through 3.8 are those displayed when the
Display SF1164 window is open and minimized.

The File menu contains options for adding, editing, viewing, canceling, and reinstating
documents, including associated acceptances, amendments, contracts, expenditures, and
receipts; printing documents; and exiting the application.

Tip  Many of the FASTDATA Site Module menu items contain submenus that allow the user to
choose a specific option associated with the selected menu item. Figure 3.2 shows the
submenu items for the Accept Document option.

Figure 3.2
File Menu
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The View menu contains viewing options for the data displayed in the current window and for
finding specific documents and document summaries.

The Reports menu contains options for opening and viewing the various FASTDATA Site
reports, such as the Status of Funds Report and Transaction History Report.

The Utilities menu contains options to access the address book, view and print site status
information, maintain credit card data, import and export data, maintain redistributions and
expenditures, perform quarterly and end-of-year processing, and recalculate obligations.

Figure 3.4
Reports Menu

Figure 3.3
View Menu

Figure 3.5
Utilities Menu
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The Tools menu provides options for changing the display of the FASTDATA toolbars,
changing your password, changing the active fiscal year, switching to another site, and enabling
or disabling the auto fill and auto display functions for documents.

Tip  Select the Auto Fill Documents item to toggle the function on and off. When checked, as
you create a new document, data from a previous like document is automatically inserted into
the new document. If you wish, you can then edit the data instead of reentering it in its entirety.
Similarly, select the Auto Display Documents item to toggle the function on and off. When
checked, after you add, amend, or update a document, the Display Document window will
display the document you just added, changed, or amended. If you turn off Auto Display, after
you add, amend, or update a document, the document window will close after you select the
Save button.

The Window menu contains options for changing the view of the open FASTDATA windows. It
also displays a list of the currently open FASTDATA windows.

The Help menu accesses the reference help file, release notes, and the About FASTDATA
window. On the help menu, users also can turn cue card help on and off and access the
FASTDATA Web site.

Figure 3.6
Tools Menu

Figure 3.7
Window Menu

Figure 3.8
Help Menu
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Toolbar
There are two FASTDATA toolbars: one associated with the main application frame and the
other associated with the current open window. The buttons that appear on the application
toolbar will depend on your FASTDATA Site access rights. The application toolbar buttons are
shortcuts to various menu items. For example, you can open a New Document window by
selecting New Document from the File menu, but it’s quicker to click on the New toolbar button.

The application toolbar contains shortcut buttons for some of the File and Help menu items. If
you have full access rights to all Site security access items on the Site User Maintenance
window of the FASTDATA FA Module, the application frame toolbar will contain the following
buttons: New, Display, Update, Print, Change Site, Exit, and What’s This Help. The actual
contents of the toolbar you see will depend on your access rights as defined in the FASTDATA
FA Module under Site Security.

The toolbar buttons do not have text labels unless you have modified your toolbar settings to
display large buttons; however, if you move your mouse cursor over a toolbar button, its tooltip
will display. A tooltip is a concise description of a graphic window control. Additionally, with the
cursor over the button, microhelp in the status bar at the bottom of the window displays the
button’s description.

Application Toolbar
Button

Function

New Opens the Select New Document Type window
Display Opens the Select Document window
Update Opens the Select Document - Update window
Print Opens the Print Multiple Documents window
Change Site Opens the Site Selection window
Exit Closes the FASTDATA Site application
What’s This Help Displays the What’s This? help cursor

Figure 3.9
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The buttons that appear on the window-specific toolbar will depend on the window(s) you have
open and whether you have data selected on the open window. Temporarily unavailable toolbar
buttons are grayed rather than full-color. For example, if you have the Address Book window
open, with the first address selected by default, the toolbar First and Previous VCR buttons will
be unavailable (grayed) because you are on the first record.

For the FASTDATA Site Module, window-specific toolbars for the windows that use a toolbar
only contain five buttons. The buttons include four VCR buttons and a Close button. The VCR
buttons are labeled like the forward and back buttons on many videocassette recorders (VCRs)
and are shortcuts to the equivalent View menu items. The First button jumps to the first record
of the accessed data. The Previous button jumps to the previous record of the accessed data.
The Next button jumps to the next record of the accessed data. The Last button jumps to the
last record of the accessed data. The toolbar also contains a Close button, which closes the
currently active window.

Figure 3.10
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Status Bar
The very bottom of the FASTDATA Site application frame contains the status bar. The status
bar keeps you informed of the status of the application and displays “microhelp.” Microhelp
provides information specific to the location of the window cursor. For example, if you move the
cursor over the Update toolbar button, the tooltip for the button will display and microhelp will
display a brief description of the button.

Window Controls and Inputs

Window Focus and Control Types
“Focus” is the current location of the window’s attention. Focus can be in a data field, a window
title, a menu, on a button, or on a line of data in a list box. The focus of the window will be
highlighted in some manner. For example, in a list box, the data row that has focus will be
highlighted with a colored bar. When a command button, such as the OK button, has focus, a
dotted line will surround the button’s label. If a data field has focus, it will contain a flashing
cursor.

A window control essentially is any object on the window that you can view, alter, or select.
Window controls include command buttons, toolbar buttons, drop-down lists, input data fields,
radio buttons, and list boxes. In this discussion of window controls, refer to the Customize
Toolbars window as an example of many of the controls you will find on FASTDATA and other
GUI application windows. In the example here, the Customize Toolbars window focus is on the
ApplicationToolbar.

Figure 3.11
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Window controls include several types of buttons. A command button is a standard Windows
control that initiates a command or sets an option. The Customize Toolbars window has four
command buttons: OK, Cancel, Apply, and Help. In the example shown in Figure 3.12, focus is
on the Cancel button.

Another type of button is the radio button, which offers a mutually exclusive choice: only one
radio button can be selected at a time. To select a radio button, click on it.

Check boxes are another type of window control. A check box displays a setting, either checked
or not checked. Unlike radio buttons, you can have more than one check box checked at a time.
Check or uncheck a check box by clicking on it. You can also change the check box setting by
shifting window focus to the check box, then pressing the SPACEBAR.

List boxes are another type of window control. A list box contains one or more rows of data. To
make a choice from a list box, you can select the desired row using your mouse or the arrow
keys.

Some Site Module windows have tabs. Window tabs are similar to the tabs in a drawer of file
folders. Tabs allow similar types of information to be grouped together, and each tab has a label
to indicate the type of information it contains. For example, on the Select New Document Type
window, there are three tabs: the Source tab, the Memo tab, and the Supplemental tab. When
focus is on one tab, you can shift focus to another tab by clicking on the tab or using the arrow
keys on the keyboard.

Figure 3.12
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In the example shown, the Select New Document Type window focus is on the Source tab.

Keyboard and Mouse Inputs
After you open a FASTDATA Site window, you can move focus around the window and
manipulate window controls using the mouse or an equivalent keyboard command. For
example, when the New Source NC2275 window opens, focus defaults to the REFERENCE
NUMBER input field. You can shift focus to the next logical field by selecting the keyboard TAB
key. With focus on the REFERENCE NUMBER input field, when you select the TAB key focus
will shift to the FUNDS EXPIRE ON input field. You can also shift focus by clicking on the
desired item. SHIFT+TAB moves focus in reverse order. To select a command button, such as
the Save button at the bottom of the New Source NC2275 window, click on the desired button.

The function keys, usually running along the top of your keyboard, perform various functions in
the FASTDATA Site application. For example, with the Site Module running, if you select the F1
key the FASTDATA Site Module Reference Help file will open. SHIFT+F1 turns on the What’s
This? help cursor. After the What’s this? help cursor displays, click on a window object to see
a description of the object. If you select CTRL+F4, you will close the currently active window. If
you wish to close all open windows and exit FASTDATA Site Module, type ALT+F4.

Function Key Function
F1 Accesses the reference help file
SHIFT+F1 Activates the What’s This? help cursor
CTRL+F4 Closes the currently active window
ALT+F4 Closes the FASTDATA Site Module

application

Figure 3.13
Select New Document
Type Window Tabs
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Common Window Features

The FASTDATA application uses a consistent interface to make it easier for you to use.
Whether you’re running the FA or Site Module, when you add, update, delete data, or view a
report, you’ll find consistency in the use of buttons, menus, and window appearance.

When you want to add new data or modify data, the basic steps are consistent from window to
window, whether you are adding a new source document or a new memorandum. You can start
the desired process from the appropriate menu or the associated toolbar button. For example,
to create a new document, select the New toolbar button. You can also select the File menu
New Document item but it’s faster to select the toolbar button.

When you have a document window open, such as the Update SF1034 window, data fields that
you can change will have a white background while view-only data fields will be gray. To change
an editable data field, shift window focus to the field, then make the desired changes. To
change a data field that features a drop-down list, shift focus to the field, then click on the drop-
down arrow or type ALT+DOWN ARROW. The drop-down list will open and you can select the
desired value from the list by highlighting it using the arrow keys or by clicking on it.

A quick way to edit any unprotected data field on a window is to right-click on the field. A
shortcut menu will display, allowing you to cut, copy, or paste all of the data field text or a
selected portion of it.

When adding new document records, FASTDATA allows you to add multiple records in one
session. For example, when you finish entering the desired data for a new SF1034 on the New
Source SF1034 window, select the Save button to save the new document. You will be asked if
you want to add another SF1034. If you select the Yes button, the window will remain open and
allow you to add additional new SF1034s.

FASTDATA will generate different types of messages for you. For example, when you initiate a
cancel action, FASTDATA will display a message prompting you to confirm the cancellation.
The cancellation will not occur until you confirm that you actually do wish to cancel the selected
document. Another type of message will inform you if FASTDATA cannot perform the action you
requested. For example, on the Select Document - Update window, if you try to select a fuel chit
to update, a message will inform you that the document cannot be selected because it contains
a receipt. FASTDATA also will generate a message if you try to save new or modified data
without an entry in a required field or if you try to enter duplicate data.

Primary vs. Secondary Windows

The main FASTDATA windows are primary windows. A primary window is a window that allows
you to access the menus, toolbar buttons, and other open primary windows. When you have a
secondary window open, the FASTDATA Site Module menus, toolbar buttons, and any other
open windows are not accessible. A secondary window is also known as a response window
because some sort of user input or response is expected on the window.

Examples of primary windows in the FASTDATA Site Module are the FASTDATA Site window
and the Address Book window. With any of these windows open, the Site Module menus are
accessible, as are the toolbar buttons.
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Examples of secondary windows in the Site Module are the various New document windows
and the Print Preview windows. With any of these windows open, the Site Module menus are
inaccessible.

Some of the FASTDATA Site Module windows are not associated with any specific source
documents, memorandum documents, or record windows. These windows include the Change
Site Password, the Change FY, Site Selection, Customize Toolbars, Printer Setup, About
FASTDATA Site, Release Notes, Select Document, and Print Multiple Documents windows.
These windows, as well as some others, are discussed in detail in later sections of this chapter
and in Chapter 8.

Using FASTDATA Help

The FASTDATA application features three kinds of help: reference, What's This?, and cue card
help.

Reference Help
Reference help opens from the Help menu Help Topics item or the toolbar Help button. You
can also open help by pressing the F1 key. On response windows, where the menus and
toolbar buttons are unavailable, there will be a Help button to let you access help. Reference
help is organized into topics.

There is a topic for every window in the Site Module. Refer to the reference help file when you
need information on the functions of a window, the length and composition of window data
fields, whether a data element requires an entry, and any user access restrictions to the
window. You can access reference help from any window in the Site Module. When you open
help, the topic that displays depends on the window from which you accessed help. Most help
topics offer jumps to related help topics. Jumps to other topics are in green, underlined text.
Glossary terms are green, with a dotted underline. When you select a glossary term, the
definition appears in a pop-up window.

Figure 3.14
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The sample reference help topic shown is a portion of the Site Login window help topic.
The reference help main windows button bar contains buttons that let you view FASTDATA Site
help contents, search for a specific topic, print the displayed topic, access the FASTDATA Site
glossary, move to the next or previous logical help topic, and access cue card help.

Cue Card Help
The Site Module also features cue card help, which contains how-to information for the Site
Module windows. Step-by-step instructions guide you through adding, canceling, modifying,
accepting, and amending different types of Site records. Cue card help is action-oriented while
reference help is information-oriented. Cue cards open and change automatically when you
open and switch between various FASTDATA windows. To suspend display of cue card help,
select the check-marked Cue Cards item on the FASTDATA Site Help menu. If you want to
again display cue cards, reselect the Help menu Cue Cards item.

The sample cue card shown contains step-by-step directions for adding a new DD1348 source
document.

What’s This? Help
The third type of FASTDATA help, What's This? help, provides definitions for every object in the
FASTDATA application. On any window, select the What's This Help toolbar button, then click
on the window object for which you want a definition. The definition displays until you perform
another mouse click or keystroke. On response windows where you cannot access the toolbar

Figure 3.15
FASTDATA Site Module
Cue Card Help
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buttons, type SHIFT+F1 simultaneously. With the What's This? pointer, click on the desired
object to access the response window element definition.

In the What's This Help example shown, a description of Line 2 on the Address Book window
displays.

Change Password Window

�  Overview

This window allows Site Module users to change their password to access the FASTDATA Site
Module.

The Change Password window opens from the Tools menu. The window also opens
automatically if you check the Forgot Password check box on the Site Login window and then
select the OK button. First, the Forgot Password window will open and allow you to provide the
correct answer to the default question you previously selected. Once you have given the
required answer and select the OK button, the window will change to the Change Password
window.

Restrictions

•  All authorized Site users have access to change their password.

Figure 3.16
FASTDATA Site
Module What’s This
Help

Figure 3.17
Opening the Change
Password Window
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•  Change Password Window Objects

Question
Select a question you'll most likely remember the answer to. You can use your favorite singer's
name, a pet's name, or other personal information.

Answer
Enter your answer to the selected question. If you forget your password, you must know the
answer to this question to access the Change Password window and enter a new password.

Password
Enter the new password. Your password must contain at least eight characters, cannot begin
with a number, and cannot contain any spaces or special characters. FASTDATA prompts you
to change your password every 90 days. When changing your password, you cannot reuse a
password you have used in the previous 12 months.

Confirm Password
Reenter the new password.

OK
Saves any password changes and closes the Change Password window.

Cancel
Aborts the change action and closes the Change Password window.

Help
Accesses the Change Password window help topic.

Figure 3.18
Change Password
Window
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� Change Password Window Options

•  Change your password

�  Steps for Changing Your Password

1. From the FASTDATA Site window, select Change Password from the Tools
menu. The Change Password window will open.

2. If this is the first time that you're changing your password, select the desired
question from the Question drop-down list, then enter the answer to the question
in the Question field. FASTDATA will remember the question and answer and
display the data as the default value the next time you access the Change
Password window. You can change to a different question and answer, if you
wish.

3. Enter your new password in the Password field. Your password must contain at
least eight characters, cannot begin with a number, and cannot contain any
spaces or special characters. When changing your password, you cannot reuse
a password you have used in the previous 12 months.

4. Reenter your new password in the Confirm Password field.

5. Select the OK button to save your changes and close the Change Password
window.

Figure 3.19
Entering and
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New Password
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Change Active Fiscal Year Window
�  Overview

This window allows Site Module users to change the active fiscal year for the current
FASTDATA session.

The Change Active Fiscal Year window opens from the Tools menu.

Restrictions

•  Access to the Change Active Fiscal Year window depends on the process you wish to
perform and the current active Site Module window.

•  Change Active Fiscal Year Window Objects

Fiscal Year
The default value is the current fiscal year. If you wish to change the currently selected fiscal
year, select a different fiscal year from the drop-down list.

OK
Applies the new selection to the current FASTDATA session and closes the Change Active
Fiscal Year window.

Cancel
Aborts the action to change the fiscal year and closes the Change Active Fiscal Year window.

Help
Accesses the Change Active Fiscal Year window help topic.

Figure 3.21
Change Active
Fiscal Year Window

Figure 3.20
Opening the Change
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Window
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� Change Active Fiscal Year Window Options

•  Change active fiscal year

�  Steps for Changing the Active Fiscal Year

1. From the FASTDATA Site window, select Change Active Fiscal Year from the
Tools menu.

The Change Active Fiscal Year window will open.

2. If you wish to change the active fiscal year, select the desired value from the
Fiscal Year drop-down list.

3. Select the OK button to save your changes and close the Change Active Fiscal
Year window.

Site Selection Window
�  Overview

This window allows site users to change the site for the current FASTDATA session, without
having to exit and restart the application. The Site Selection window is unavailable if you have
access to only one site. For users with access to more than one site, this window also opens
automatically when you start the Site application, allowing you to select the desired site for the
FASTDATA session.

The Site Selection window opens from the Tools menu.

Figure 3.22
Changing the Active
Fiscal Year

Figure 3.23
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Restrictions

•  Access to the Site Selection window depends on whether the user has access to more
than one site.

•  Site Selection Window Objects

Sites
Lists the sites available to you from which you can select.

OK
Applies the new selection to the current FASTDATA session and closes the Site Selection
window.

Cancel
Aborts the action to change to a different site and closes the Site Selection window.

Help
Accesses the Site Selection window help topic.

� Site Selection Window Options

•  Change site for current session

Figure 3.24
Site Selection
Window
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�  Steps for Changing Site for Current Session

1. From the FASTDATA Site window, select Change Site from the Tools menu.

The Site Selection window will open.

2. Select the site that you wish to change to from the Sites list box.
3. Select the OK button to complete your change and close the Site Selection

window.

If the site you selected has been locked, a message will inform you so. When a site
is locked, you will have full access, display-only access, or no access to the site, as
set by your FA. After you select OK on the message, if you have no access to the
locked site, the Site application will close. If you have view-only access to the locked
site, you will only be able to view reports and documents. If you have full access, you
will have your normal access to the locked site.

Customize Toolbars Window

�  Overview

Users can modify the appearance and location of the FASTDATA toolbars on the Customize
Toolbars window. If you open the Customize Toolbars window from the application frame, the
only toolbar that you can modify is the Application Toolbar. To have access to modify both the
Application Toolbar and the Window-Specific toolbar, open a window that has a toolbar
associated with it before you open the Customize Toolbars window. For example, with the
Display DD1348 window open, its associated toolbar will display.

Figure 3.25
Changing Site for
Current Session
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The Customize Toolbars window opens from the Tools menu.

Restrictions

•  Access to the Customize Toolbars window is unrestricted.

•  Customize Toolbars Window Objects

Toolbars
The Application Toolbar check box controls the display of the toolbar associated with the
FASTDATA application frame (window). The Window-Specific Toolbar check box controls the
display of the toolbar associated with the current FASTDATA Site Module window.

Position
Controls the location of the toolbars.

Top
Places the selected toolbar below the menu bar.

Figure 3.27
Customize Toolbars
Window

Figure 3.26
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Bottom
Places the selected toolbar above the status bar.

Left
Places the selected toolbar down the left side of the window.

Right
Places the selected toolbar down the right side of the window.

Floating
Places the toolbar in a moveable box.

Application settings
Provides further options for toolbar displays in FASTDATA.

Large Buttons
Controls whether large or small toolbar buttons display. Large buttons contain text labels as well
as pictures.

Show Tooltips
Controls whether the toolbar button's tooltip displays when the mouse cursor is over a toolbar
button. A tooltip identifies the function of the button.

OK
Accepts the toolbar settings and closes the Customize Toolbars window.

Cancel
Aborts any changes made to the toolbar settings and closes the Customize Toolbars window.

Apply
Lets you see how any toolbar changes you've made will look. If you don't like the changes, you
can undo them before you close the Customize Toolbars window.

Help
Accesses the Customize Toolbars window help topic.

� Customize Toolbars Window Options

•  Change Application and Window-Specific Toolbar Settings

�  Steps for Changing Application and Window-Specific
Toolbar Settings

1. To have access to modify both the Application Toolbar and the Window-Specific
toolbar, open a window within the Site Module that has an associated toolbar and
select Customize Toolbar from the Tools menu.
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The Customize Toolbars window will open.

This example shows the open Customize Toolbars window with the Display DD1348
window open. If you open the Customize Toolbars window from the application
frame, the only toolbar that you can modify is the Application Toolbar.

2. Check or uncheck the desired FASTDATA toolbars. The Application Toolbar
check box controls the display of the toolbar associated with the main
FASTDATA Site application window. The Window-Specific Toolbar check box
controls the display of the toolbar on any other window that has an associated
toolbar; the Window-Specific Toolbar buttons vary, depending on which
window is open.

3. Modify the location of the toolbar by selecting the desired Position radio button.
4. Modify the appearance of the toolbar buttons by checking or unchecking one or

both Application settings check boxes.
5. Select the Apply button to see how the new settings will affect the toolbar.

 

Figure 3.28
Changing
the Toolbar
Settings
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This example shows the Large Buttons and Show Tooltips options selected for all
toolbar buttons, with the Bottom Position selected for the Display DD1348 window
toolbar.

6. Select the OK button to save the new settings and close the Customize Toolbars
window.

Printer Setup Window

�  Overview

Users can change the printer selection and print options from the Printer Setup window.

The Printer Setup window opens from the File menu.

Figure 3.29
New Toolbar
Display

Figure 3.30
Opening the Printer
Setup Window
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Restrictions

•  Access to the Printer Setup window is unrestricted.

•  Printer Setup Window Objects

OK
Accepts the printer settings and closes the Printer Setup window.

Cancel
Aborts any changes made to the printer settings and closes the Printer Setup window.

Setup
Opens the Document Properties window for the selected printer, allowing you to change page
setup and advanced print options.

� Printer Setup Window Options

•  Change printer and print criteria

Figure 3.31
Printer Setup
Window
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�  Steps for Changing Printer and Print Criteria Settings

1. From the FASTDATA Site window, select Print Setup from the File menu.

The Printer Setup window will open.

2. Select the desired printer from the Printer list box.
3. If desired, select the Setup button to change the print criteria. The Document

Properties window for the selected printer will open.

Figure 3.32
Selecting the
Desired Printer

Figure 3.33
Changing the
Print Criteria
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4. Select the desired tab and print options. The Page Setup tab is selected by
default. In the example shown, data will be printed on letter-size paper in the
portrait format. The selected number of copies is one.

5. Select the OK button to close the Document Properties window.
6. Select the OK button to close the Printer Setup window.

About FASTDATA Site Window

�  Overview

The About FASTDATA Site window provides users with information about the version of the
FASTDATA Site application they are running, the current user's ID, the database to which the
user is connected, the associated FA, and the site identifier. Additionally, the information box
will indicate if the user's computer system is lacking a required FASTDATA font. A missing font
may cause display problems when you're running the application or it may cause some reports
to display or print incorrectly.

You can copy and paste the contents of the information box into another application, such as
WordPad or Microsoft Word, so that you can print it or send the message to someone who may
be able to help you resolve the missing font problem.

The About FASTDATA Site window opens from the Help menu.

Restrictions

•  Access to the About FASTDATA Site window is unrestricted.

Figure 3.34
Opening the
About
FASTDATA
Site Window
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•  About FASTDATA Site Window Objects

Version Information and Text Box
Provides information about the version of FASTDATA Site Module you are running, your user
ID, database name, associated FA, and site name under which you logged on.

OK
Closes the About FASTDATA Site window.

Help
Accesses the About FASTDATA Site window help topic.

� About FASTDATA Site Window Options

•  View and copy About FASTDATA Site window text

Figure 3.35
About FASTDATA
Site Window
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�  Steps for Viewing and Copying About FASTDATA
Site Window Text

1. From the FASTDATA Site window, select About from the Help menu.

The About FASTDATA Site window will open.

2. If you wish to copy the contents of the information box on the About FASTDATA
Site window into another application, click on the information box, then right-click
your mouse. A floating menu will display.

3. Select Select All from the floating menu, then right-click again. The floating
menu will reappear.

4. Select Copy from the floating menu.
5. Open the desired application, such as WordPad or Microsoft Word, and paste the

information box contents into the new file. You can paste by typing CTRL+V or
by selecting Paste from the Edit menu.

6. If you wish, you can then print the file, save the file, or send the file to someone
who may be able to help you resolve a missing font problem, if applicable.

Release Notes Window

�  Overview

When a new version of the FASTDATA Site Module is released, the accompanying release
notes provide helpful information about the new release.

Figure 3.36
Copying the About
FASTDATA Site
Information Box Text
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The Release Notes window opens from the FASTDATA Site Help menu.

Restrictions

•  Access to the Release Notes window is unrestricted.

•  Release Notes Window Objects

Information Box
Provides information about the version of the FASTDATA Site Module you are using, including
information on any SCRs incorporated into the release.

OK
Closes the Release Notes window.

Print
Opens the Quick Print window, allowing you to print the release notes.

Help
Opens the Release Notes window help topic.

Figure 3.38
Release Notes Window

Figure 3.37
Opening the
Release Notes
Window
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� Release Notes Window Options

•  View and print Release Notes

�  Steps for Viewing and Printing Release Notes

1. From the FASTDATA Site window, select Release Notes from the Help menu.

The Release Notes window will open.

2. If the release notes extend past the visible area of the text box, use the scroll bar
on the right to scroll down.

3. Select the Print button if you wish to print the release notes.

Figure 3.39
Printing the
Release
Notes
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The Quick Print - Release Notes window will open.

4. Select the Save As picture button if you wish to save the release notes data in a
file.

5. Select the Print picture button to print the release notes.
6. Select the Rulers picture button if you wish to see vertical and horizontal rulers

on the window.
7. Select the Margin Offset picture button if you wish to increase the margin. The

wider margin allows for the punching of holes on the printed release notes report.
8. Use the VCR buttons to view the first, next, previous, and last pages of the

release notes, if applicable.
9. Select the Zoom picture button if you wish to change the percent of magnification

of the displayed release notes.
10. Select the desired page orientation from the drop-down list: Landscape or

Portrait.
11. Select the Close button to close the Quick Print window.
12. Select the OK button to close the Release Notes window.

Figure 3.40
Quick Print -
Release Notes
Window

Save As

Print Margin Offset

Rulers
Zoom
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Select Document Window

�  Overview

Use this window to select desired Site source and memorandum documents to view. You also
can use the window to select a document for which you wish to view a summary of. Both
options are discussed in detail.

The Select Document - Display window opens from the FASTDATA Site File menu.

Restrictions

•  Access to view Site source and memorandum documents is unrestricted.

•  Only users with a FASTDATA FA Module Site User Maintenance window Site Security
Access Print Document access level of Access can print source documents.

•  A FASTDATA FA Module Site User Maintenance window Site Security Access Print
Document access level of No Access prevents a user from printing source documents.

NOTE  Other than memo Credit Card documents, you cannot print any of the remaining memo
documents in the FASTDATA Site Module.

Figure 3.41
Opening
the Select
Document
Window
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•  Select Document Window Objects

Select the search type
You can search by DCN, Local Code, OPTAR Log, or Vendor. Select the desired value from
the drop-down list.

Enter the search item
Allows you to enter the desired value for the selected search type. For example, if you selected
DCN for the search type, enter the desired DCN in this field.

Select the sort order
Allows you to change the sort order of the data displayed on the Select Document window.
Select the desired value from the drop-down list. Valid values include Created Date, DCN,
Document Type, Local Code, Optar Log, and Serial Number.

Ascending
Select the Ascending radio button if you wish to sort the selected sort order data in ascending
order.

Descending
Select the Descending radio button if you wish to sort the selected sort order data in
descending order.

DCN
Identifies the 15-character Standard Document Number (SDN), the 14-character Requisition
Number (MILSTRIP/MILSTRAP), or the 13-character Procurement Instrument Identification
Number (PIIN)/Contract Number.

Amend
Identifies a specific official amendment to a previously established financial document.

Memo
Indicates whether the document is a source document or memorandum.

Figure 3.42
Select Document
Window
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Status
Indicates a document or document number's current status. For a listing of currently used
values and corresponding definitions, refer to the Document Status Values topic in the
FASTDATA Site Reference Help.

Exported
Indicates whether the document has been exported to the FA; the system assigns this value
when the record is exported to the FA.

OPTAR Log
Identifies the purpose of the OPTAR Log entry that will be printed on the OPTAR Log, or the
name(s) of items being requisitioned.

Document Type
Identifies a specific document form number.

Local Code
A code of up to 20 characters that identifies document types and groupings for reporting
purposes.

Vendor
Identifies the organization, person, or entity providing services or filing a claim for
reimbursement. The actual value depends on the document type.

Created Date
Lists the date and time that a document was created.

OK
Accepts your document selection and closes the Select Document window.

Cancel
Aborts the action to select a document.

Help
Accesses the reference help topic on the Select Document window.

� Display Document and Display Document Summary
Options

•  View source and memorandum documents

•  View a summary of source and memorandum documents
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�  Steps for Viewing Source and Memorandum
Documents

1. From the FASTDATA Site window, select Display Document from the File
menu.

Tip  You can also select the Display toolbar button to open the Select Document
window.

The Select Document - Display window will open and a list of Site documents will
display.

2. Select the document you wish to view and select the OK button.

FASTDATA will inform you if supplemental documents exist for the document that
you have selected to view.

Select Yes if you wish to view a supplemental document. The Select Supplemental
Document window will open and allow you to select the supplemental document that
you wish to view. Select No if you do not wish to view a supplemental document.

Figure 3.43
Selecting a
Document to
View

Figure 3.44
Supplemental
Documents
Message
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The Display window for the selected document type will open. For the example
shown, a DD448 has been selected. Note that the document header indicates the
status, whether it has been exported to the FA, and, if applicable, the external
system it was sent to.

Use the horizontal and vertical scrollbars to scroll through the document. If desired,
on documents that contain long line of accounting (LOA) data and line item data, you
can view details on the displayed data.

3. To view details, right-click on the desired line item or accounting classification
reference number (ACRN) data. Select View from the shortcut menu.

The View Line Item window, View ACRN window, or View ACRN for Off-Site
Contract window will open and details on the selected data will display. The example
in Figure 3.46 shows Line Item details for the item selected in Figure 3.45.

4. Select the Close button to close the View Line Item window, the View ACRN
window, or the View ACRN for Off-Site Contract window, as applicable.

5. If you wish to print the displayed source document, select Print Documents from
the File menu or select the Print toolbar button. The Print Multiple Documents
window will open and allow you to select the source document that you wish to
print.

Figure 3.45
Viewing
Document
Details

Figure 3.46
Viewing Line
Item Details
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6. If you wish to view another document of the same type displayed, select Find
from the View menu.

Tip  You can also use the VCR buttons, if available for selection, on the Display
window toolbar to view other documents of the type displayed.

The Find Document window will open. A list of like document types in the
FASTDATA database will display.

7. Select the document you wish to view and select the OK button. The Find
Document window will close and the selected document will display.

8. Select the Close button on the Display window title bar, or window-specific
toolbar, to close the window.

�  Steps for Viewing a Summary of Source and
Memorandum Documents

1. From the FASTDATA Site window, select Display Document Summary from
the File menu.

The Select Document – Display Summary window will open and a list of Site
documents will display.

Figure 3.47
Opening the
Find Document
Window

Figure 3.48
Find Document
Window
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NOTE  You cannot view a document summary for DD1131, DD1155, NC2061, SF30,
and SF1034 documents.

2. Select the document you wish to view a summary of and select the OK button.

The Display Summary window will open. For the example shown, a summary of a
DD282 has been selected to view.

Use the horizontal and vertical scrollbars to scroll through the document summary.

3. If you wish to view another document summary, select Find from the View menu.

Tip  You can also use the VCR buttons on the Display Summary window toolbar, if
available for selection, to view other documents summaries of the type displayed.

The Find Document window will open. A list of documents for which you can view a
summary of will display.

4. Select the document you wish to view a summary of and select the OK button.
The Find Document window will close and the selected document summary will
display.

5. Select the Close button on the Display Summary window title bar, or window-
specific toolbar, to close the window.

Figure 3.49
Viewing
Document
Summary
Details
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Print Multiple Documents Window

�  Overview

Use the Print Multiple Documents window to print multiple source documents without first having
to open them.

The Print Multiple Documents window opens from the File menu.

Restrictions

•  Only users with a FASTDATA FA Module Site User Maintenance window Site Security
Access Print Document access level of Access can print documents.

•  A FASTDATA FA Module Site User Maintenance window Site Security Access Print
Document access level of No Access prevents a user from printing documents.

NOTE  Other than memo Credit Card documents, you cannot print any of the remaining memo
documents in the FASTDATA Site Module.

Figure 3.50
Opening the Print
Multiple Documents
Window
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•  Print Multiple Documents Window Objects

Select the search type
You can search by DCN, Local Code, OPTAR Log, or Vendor. Select the desired value from
the drop-down list.

Enter the search item
Allows you to enter the desired value for the selected search type. For example, if you selected
DCN for the search type, enter the desired DCN in this field.

Select the sort order
Allows you to change the sort order of the data displayed on the Select Document window.
Select the desired value from the drop-down list. Valid values include Created Date, DCN,
Document Type, Local Code, OPTAR Log, and Serial Number.

Ascending
Select the Ascending radio button if you wish to sort the selected sort order data in ascending
order.

Descending
Select the Descending radio button if you wish to sort the selected sort order data in
descending order.

Document Type Tab
Displays a list of document types available for printing.

Documents Tab
Displays a list of documents for the selected type that are available for printing.

Figure 3.51
Print Multiple
Documents Window
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Printed Documents
Displays a list of documents that you have printed.

Print
Prints the selected document(s).

Close
Closes the Print Multiple Documents window.

Help
Opens the reference help topic on the Print Multiple Documents window.

� Print Multiple Documents Window Options

•  Print multiple documents

�  Steps for Printing Multiple Documents

1. From the FASTDATA Site window, select Print Documents from the File menu.

The Print Multiple Documents window will open with the Document Type tab
selected by default. Available document types will display.

Tip  You can also select the Print toolbar button to open the Print Multiple
Documents window.

Figure 3.52
Selecting a
Document
Type to Print
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2. On the Document Type tab, select the type of document you wish to print.

Tip  When the Print Multiple Documents window opens, all available document types
are selected on the Document Type tab. To select a single document type, click on
the desired type. To select consecutive document types, select the first type, hold
down the SHIFT key, and select the last type that you wish to print. To select random
document types, select the first type, hold down the CONTROL key, and select the
other remaining document types that you wish to print.

3. Select the Documents tab and select the desired search type from the Select
the search type drop-down list.

4. Enter the desired value for the selected search type in the Enter the search
item field. For example, if you selected DCN for the search type, enter the
desired DCN in this field.

5. If you wish to change the sort order of the listed documents, select the desired
value from the Select the sort order drop-down list.

6. If you wish to change the sort order of the listed documents, select the desired
sort order type radio button: Ascending or Descending.

Tip  When you first select the Documents tab, all listed documents are selected by
default. You can unselect the documents you do not wish to print.

7. Select the desired Filter Option radio button: My Documents or All
Documents.

8. Select the Print button to print the selected document(s).

Figure 3.53
Selecting a
Document to
Print
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After you select the Print button, if you are printing NC2275 or NC2276 type
documents, a message will prompt you to indicate whether you want to print the
corresponding instruction sheets. Select Yes if you want to print the instructions.

If you selected a DD1348 to print, the Select Print Format window will open, allowing
you to indicate whether you want to print both the form and the form data and
whether you want to print more than one DD1348 per page. To print both the
DD1348 form and the form data, make sure the Laser check box is checked. If
you're using an ALPS printer, uncheck the Laser check box.

Select the 2-UP radio button to print the data for two DD1348 documents per page.
With the Laser check box checked, two DD1348 forms and their data will print per
page. Select the 3-UP radio button to print the data for three DD1348 documents per
page. With the Laser check box checked, three DD1348 forms and their data will
print per page. If you're using an ALPS printer, uncheck the Laser check box. Select
the OK button to close the window and print the document(s).

Tip  If you wish to review the list of printed documents, select the Printed
Documents tab before closing the Print Multiple Documents window.

Tip  Documents that you have previously printed will not display on the Documents
tab. If you wish to print a previously printed document again, select the Printed
Documents tab, select the desired document, and select the Print button.

Figure 3.55
Printing a DD1348

Figure 3.54
NC2276 Printing
Instruction Sheet
Option
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9. Select the Close button to close the Print Multiple Documents window.

Site Documents Quick Overview
The table on the next page provides you a quick summary of FASTDATA Site documents, the
types of transactions they initially create, and related processes. Refer to the Site Documents at
a Glance FASTDATA Help topic for an explanation of the various transaction type codes.

Figure 3.56
Printed
Documents
Tab
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Document
Name/
Number

Description Initial
Transactio
n Type

Source,
Memo, Both,
or
Supplemental

Multiple/
Single
ACRN

Line
Items

Amend Accept Contract

Civilian Labor EC Memo M N N N N

Credit Card AO Memo S Y N Y N

DD1131 Cash Collection Voucher N/A Supp M N N N N

DD1149 Requisition & Invoice/Shipping
Document

CM Both S Y N N Y

DD1155 Contract for (DD1149, DD448,
NC2276)

AO Supp M Y N N/A N/A

DD1348 MILSTRIP Requisition AO Both S N N N N

DD1348-6 MILSTRIP Req (Long Form) CM Both S N N N Y

DD1556 Training Request Agreement AO Both S Y Y Y N

DD1610 Travel Order (TAD only) AO Memo M N N N N

DD282 Printing Request/Order AO Both S N Y N N

DD448 Military Interdepartmental Request
(MIPR)

CM Both M Y Y Y Y

Fuel Chits RG Memo S N N N N

GSA
Document

GSA AO Memo M N N N N

Miscellaneous AO Memo M N N N N

NAVPERS
1320/16

NAVPERS Travel Order (TAD only) AO Memo M N N N N

NC2061 Utility Invoice/Certification N/A Supp M N N N N

NC2275 Order for Work & Services CM Both M N Y Y N

NC2276 Request for Contractual
Procurement

CM Both M Y Y Y Y

SF1034 Public Voucher for Purchases &
Services

N/A Supp M N N N N

SF1164 Claim for Reimbursment RP Both M Y N N N

SF30 Mod to 1155 AO Supp M N N N/A N/A

SF44 Purchase Order/Invoice Voucher RP Memo S N N N N


